Pipenv fails on deploy when installing package from commit

Priority: High
Request:
Project ID: 18898
Project Link: https://app.crowdbotics.com/dashboard/app/18898
Staging Link:
Additional Info: I have installed a package from one of its unmerged commits, this installs successfully locally but fails to install on deployment.

error

[91mAn error occurred while installing git+https://github.com/0leg5ergeev/django-allauth.git@c8750bf418846c441d2970e56958a3d41476176d#egg=django-allauth --hash=sha256:7ab91485b80d231da191d5c7999ba93170ef1bf14ab6487d886598a1ad03e1d8! Will try again.

[0mInstalling initially failed dependencies…
e[91m[pipenv.exceptions.InstallError]: File “/usr/local/lib/python3.6/dist-packages/pipenv/cli/command.py”, line 254, in install
e[0me[91m[pipenv.exceptions.InstallError]: editable_packages=state.installstate.editables,
[pipenv.exceptions.InstallError]: File “/usr/local/lib/python3.6/dist-packages/pipenv/core.py”, line 1874, in do_install
e[0me[91m[pipenv.exceptions.InstallError]: keep_outdated=keep_outdated
e[0me[91m[pipenv.exceptions.InstallError]: File “/usr/local/lib/python3.6/dist-packages/pipenv/core.py”, line 1253, in do_init
[pipenv.exceptions.InstallError]: pypi_mirror=pypi_mirror,
e[0me[91m[pipenv.exceptions.InstallError]: File “/usr/local/lib/python3.6/dist-packages/pipenv/core.py”, line 862, in do_install_dependencies
[pipenv.exceptions.InstallError]: _cleanup_procs(procs, False, failed_deps_queue, retry=False)
e[0me[91m[pipenv.exceptions.InstallError]: File “/usr/local/lib/python3.6/dist-packages/pipenv/core.py”, line 681, in _cleanup_procs
[pipenv.exceptions.InstallError]: raise exceptions.InstallError(c.dep.name, extra=err_lines)
e[0me[91m[pipenv.exceptions.InstallError]: []
e[0me[91m[pipenv.exceptions.InstallError]: [“Invalid requirement: ‘–hash=sha256:7ab91485b80d231da191d5c7999ba93170ef1bf14ab6487d886598a1ad03e1d8’”, ‘= is not a valid operator. Did you mean == ?’]
ERROR: ERROR: Package installation failed…

cc @jorge.m

It looks like you’re using a fork of django-allauth. Why aren’t you using the official package?

This is for apple auth, its not yet implemented there. This fork is trying to implement but it going to be sometime before it gets merged

I’m not sure what’s causing these issues. You tried running it in Docker locally and it worked?

uhh no, I running without docker. I was investigating this a bit, it seems to be because of --system. Any suggestion as to how to handle this alternatively?

@Crowdbotics_Dan just a follow up here. Any alternative or any example you can refer?